BaseImportOptionsSetLayerSelection Method |
Set the layers name which user want to import into Revit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLayerSelection(
ICollection<string> layerSelection
)
Public Sub SetLayerSelection (
layerSelection As ICollection(Of String)
)
public:
void SetLayerSelection(
ICollection<String^>^ layerSelection
)
member SetLayerSelection :
layerSelection : ICollection<string> -> unit
Parameters
- layerSelection ICollectionString
-
The layers imported into Revit.
Exceptions
Remarks
If user don't set any layer selection, all layers would be imported into Revit for dgn.
But for dwg|dxf, all layers (or visible layers, it is up to visibleLayersOnly was set or not) would be imported into Revit.
See Also