ElementId Class

The ElementId object is used as a unique identification for an element within a single project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementId

The ElementId type exposes the following members.

Constructors
 NameDescription
Public methodElementId(BuiltInCategory) Create an ElementId handle with the given BuiltInCategory id.
Public methodElementId(BuiltInParameter) Create an ElementId handle with the given BuiltInParameter id.
Public methodElementId(Int32)Obsolete.
Create an ElementId handle with the given 32-bit integer id.
Public methodElementId(Int64) Create an ElementId handle with the given 64-bit integer id.
Top
Properties
 NameDescription
Public propertyIntegerValueObsolete.
Provides the value of the element id as a 32-bit integer.
Public propertyStatic memberInvalidElementId Get the invalid ElementId whose value is -1.
Public propertyValue Provides the value of the element id as a 64-bit integer.
Top
Methods
 NameDescription
Public methodCompareCompares two element ids.
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Overrides ObjectEquals(Object))
Public methodGetHashCode Gets the value of the id as hash code
(Overrides ObjectGetHashCode)
Public methodStatic memberParse Parse the string representation of the id into a corresponding ElementId.
Public methodToString Gets a String representation of the value of the id.
(Overrides ObjectToString)
Public methodStatic memberTryParse Parse the string representation of the id into a corresponding ElementId.
Top
Operators
 NameDescription
Public operatorStatic memberEquality(ElementId, ElementId)Determines whether these two ElementIds are the same.
Public operatorStatic memberGreaterThan(ElementId, ElementId)Determines whether one element id is greater than another element id.
Public operatorStatic memberGreaterThanOrEqual(ElementId, ElementId)Determines whether one element id is not less than another element id.
Public operatorStatic memberInequality(ElementId, ElementId)Determines whether these two ElementIds are different.
Public operatorStatic memberLessThan(ElementId, ElementId)Determines whether this element id is less than another element id.
Public operatorStatic memberLessThanOrEqual(ElementId, ElementId)Determines whether one element id is not greater than another element id.
Top
Remarks
The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.
See Also