Parse the string representation of the id into a corresponding ElementId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId Parse(
string idStr
)
Public Shared Function Parse (
idStr As String
) As ElementId
public:
static ElementId^ Parse(
String^ idStr
)
static member Parse :
idStr : string -> ElementId
Parameters
- idStr String
- The string representation of the id to return.
Return Value
ElementIdElementId string represented.
Exceptions
Remarks
If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] it will be returned.
See Also