IFCProductWrapperAddSpace Method |
Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddSpace(
IFCAnyHandle spaceHandle,
IFCLevelInfo pLevelInfo,
IFCExtrusionCreationData pParams,
bool relateToLevel
)
Public Sub AddSpace (
spaceHandle As IFCAnyHandle,
pLevelInfo As IFCLevelInfo,
pParams As IFCExtrusionCreationData,
relateToLevel As Boolean
)
public:
void AddSpace(
IFCAnyHandle^ spaceHandle,
IFCLevelInfo^ pLevelInfo,
IFCExtrusionCreationData^ pParams,
bool relateToLevel
)
member AddSpace :
spaceHandle : IFCAnyHandle *
pLevelInfo : IFCLevelInfo *
pParams : IFCExtrusionCreationData *
relateToLevel : bool -> unit
Parameters
- spaceHandle IFCAnyHandle
-
The IfcSpace handle.
- pLevelInfo IFCLevelInfo
-
Information on the associated level.
- pParams IFCExtrusionCreationData
-
The extrusion creation data associated with the given space. Optional, can be .
- relateToLevel Boolean
-
True to relate the space to the level, false otherwise.
Exceptions
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
See Also