IFCProductWrapperAddAnnotation Method |
Adds an annotation handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddAnnotation(
IFCAnyHandle annoHnd,
IFCLevelInfo levelInfo,
bool relateToLevel
)
Public Sub AddAnnotation (
annoHnd As IFCAnyHandle,
levelInfo As IFCLevelInfo,
relateToLevel As Boolean
)
public:
void AddAnnotation(
IFCAnyHandle^ annoHnd,
IFCLevelInfo^ levelInfo,
bool relateToLevel
)
member AddAnnotation :
annoHnd : IFCAnyHandle *
levelInfo : IFCLevelInfo *
relateToLevel : bool -> unit
Parameters
- annoHnd IFCAnyHandle
-
The annotation handle.
- levelInfo IFCLevelInfo
-
Information on the associated level. Optional, can be .
- relateToLevel Boolean
-
True to relate the annotation to the level, false otherwise.
Exceptions
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
See Also