IFCProductWrapperCreate(IFCProductWrapper, Boolean) Method

Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCProductWrapper Create(
	IFCProductWrapper pProductWrapper,
	bool allowRelateToLevel
)

Parameters

pProductWrapper  IFCProductWrapper
The parent product manager.
allowRelateToLevel  Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

IFCProductWrapper
The new product manager.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also