IFCProductWrapperCreate(ExporterIFC, Boolean) Method |
Establishes a new baseline product manager for elements and objects.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IFCProductWrapper Create(
ExporterIFC ExporterIFC,
bool allowRelateToLevel
)
Public Shared Function Create (
ExporterIFC As ExporterIFC,
allowRelateToLevel As Boolean
) As IFCProductWrapper
public:
static IFCProductWrapper^ Create(
ExporterIFC^ ExporterIFC,
bool allowRelateToLevel
)
static member Create :
ExporterIFC : ExporterIFC *
allowRelateToLevel : bool -> IFCProductWrapper
Parameters
- ExporterIFC ExporterIFC
-
The exporter.
- allowRelateToLevel Boolean
-
True to allow associated elements and objects to relate to a level, false to never allow such a
relationship.
Return Value
IFCProductWrapper
The new baseline product manager.
Exceptions
Remarks
Elements and objects associated to this product manager will be associated to a top-level IfcProduct based on the world coordinate
system of the output file.
See Also