IFCProductWrapperAddElement Method |
Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddElement(
IFCAnyHandle elementHandle,
IFCLevelInfo pLevelInfo,
IFCExtrusionCreationData params,
bool relateToLevel
)
Public Sub AddElement (
elementHandle As IFCAnyHandle,
pLevelInfo As IFCLevelInfo,
params As IFCExtrusionCreationData,
relateToLevel As Boolean
)
public:
void AddElement(
IFCAnyHandle^ elementHandle,
IFCLevelInfo^ pLevelInfo,
IFCExtrusionCreationData^ params,
bool relateToLevel
)
member AddElement :
elementHandle : IFCAnyHandle *
pLevelInfo : IFCLevelInfo *
params : IFCExtrusionCreationData *
relateToLevel : bool -> unit
Parameters
- elementHandle IFCAnyHandle
-
The IfcElement handle.
- pLevelInfo IFCLevelInfo
-
The level info.
- params IFCExtrusionCreationData
-
The extrusion creation data associated with the given element. Optional, can be .
- relateToLevel Boolean
-
True to relate the element to the level, false otherwise.
Exceptions
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
See Also