TableCellStyle Class

The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTableCellStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TableCellStyle : IDisposable

The TableCellStyle type exposes the following members.

Constructors
 NameDescription
Public methodTableCellStyle Constructs a new TableCellStyle with default settings.
Public methodTableCellStyle(TableCellStyle) Constructs a new copy of the input TableCellStyle object.
Top
Properties
 NameDescription
Public propertyBackgroundColor The background color of this cell in the grid view.
Public propertyBorderBottomLineStyle The element id (GraphicsStyle element) for the bottom line of the cell border.
Public propertyBorderLeftLineStyle The element id (GraphicsStyle element) for the left line of the cell border.
Public propertyBorderRightLineStyle The element id (GraphicsStyle element) for the right line of the cell border.
Public propertyBorderTopLineStyle The element id (GraphicsStyle element) for the top line of the cell border.
Public propertyFontHorizontalAlignment The horizontal alignment style of text font.
Public propertyFontName The font used for this style
Public propertyFontVerticalAlignment The vertical alignment style of text font.
Public propertyIsEnabled Gets or sets the status whether this cell is enabled.
Public propertyIsFontBold Gets or sets whether the text font is set to bold of this cell.
Public propertyIsFontItalic Gets or sets whether the text font is set to italic of this cell.
Public propertyIsFontUnderline Gets or sets whether the text font is set to Underline of this cell.
Public propertyIsInactivePhaseload Gets or sets whether this is an inactive phase load cell.
Public propertyIsOverridden Indicates if the cell is overridden or not.
Public propertyIsReadOnly Gets or sets whether this cell is read only.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySheetBackgroundColor The background color of this cell in the sheet view.
Public propertyTextColor The text color of this cell.
Public propertyTextOrientation The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public propertyTextSize The text size.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TableCellStyle
Public methodGetCellStyleOverrideOptions Gets cell style override options of this cell.
Public methodResetOverride Resets any overrides applied to this cell.
Public methodCode exampleSetCellStyleOverrideOptions Sets cell style override options of this cell.
Top
See Also