TemporaryViewModes Class

A data structure containing data related to temporary view modes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBTemporaryViewModes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TemporaryViewModes : APIObject

The TemporaryViewModes type exposes the following members.

Properties
 NameDescription
Public propertyCustomColor Custom color for the TemporaryViewProperties mode.
Public propertyCustomTitle Custom title for the TemporaryViewProperties mode.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyCode examplePreviewFamilyVisibility The current state of the PreviewFamilyVisibility mode in the associated view.
Public propertyStatic memberCode examplePreviewFamilyVisibilityDefaultOnState Controls the default state of the PreviewFamilyVisibility mode in all views.
Public propertyStatic memberPreviewFamilyVisibilityDefaultUncutState Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public propertyRevealConstraints The current state of the RevealConstraints mode in the associated view.
Public propertyRevealHiddenElements The current state of the RevealHiddenElements mode in the associated view.
Public propertyWorksharingDisplay The current state of the WorksharingDisplay mode in the associated view.
Top
Methods
 NameDescription
Public methodDeactivateAllModes Deactivates all temporary modes that are currently active.
Public methodDeactivateMode Deactivates the given temporary mode.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCaption A text caption to use for the given mode.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCustomized Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public methodIsModeActive Tests whether a given mode is currently active or not.
Public methodIsModeAvailable Tests whether a temporary view mode is currently available in the associated view.
Public methodIsModeEnabled Tests whether a temporary view mode is currently enabled in the associated view.
Public methodIsValidState Tests whether the given state is valid for the associated view and the context the view is currently in.
Public methodRemoveCustomization Removes all customized values for the TemporaryViewProperties mode.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

The class contains methods and properties to manipulate states of various temporary view modes that may or may not be avilable in any of visible views of a Revit document. The temporary modes are enumerated in the TemporaryViewMode class.

Every view that supports temporary view modes owns an instance of this TemporaryViewModes class, which can be obtained by accessing the TemporaryViewModes property of the View class. Note that views which do not support temporary modes will have that property's value be Null.

Multiple temporary view modes can coexist. Also, TemporaryViewProperties mode can be customized to display custom title and custom color. Setting custom title and color affects only TemporaryViewProperties mode for the specific view.

Example
public bool RevealHiddenElementsInView(View view)
{
    bool hiddenRevealed = false;
    TemporaryViewModes viewModes = view.TemporaryViewModes;

    if (viewModes == null)
    {
        TaskDialog.Show("Invalid View", "This view does not support temporary view modes.");
    }
    else
    {
        // Mode must be available and enabled to be activated
        if (viewModes.IsModeEnabled(TemporaryViewMode.RevealHiddenElements) && viewModes.IsModeAvailable(TemporaryViewMode.RevealHiddenElements))
        {
            viewModes.RevealHiddenElements = true;
            hiddenRevealed = viewModes.RevealHiddenElements;
        }
    }

    return hiddenRevealed;
}
See Also