TemporaryViewMode Enumeration |
Enumeration to represent the various temporary view modes a view can be in.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum TemporaryViewMode
Public Enumeration TemporaryViewMode
public enum class TemporaryViewMode
MembersMember name | Value | Description |
---|
RevealHiddenElements | 1 |
The view is in reveal hidden elements mode
|
TemporaryHideIsolate | 2 |
The view is in temporary hide/isolate mode
|
WorksharingDisplay | 3 |
The view is in one of the worksharing display modes
|
TemporaryViewProperties | 4 |
The view is in the selected View Properties applied temporarily.
|
ExplodedView | 6 |
The view is in the mode that shows the model in exploded view and allows user changes/configurations
|
RevealConstraints | 7 |
The view is in the mode that reveals constraints between elements in the model.
|
PreviewFamilyVisibility | 8 |
The view is in the mode that shows visibility settings applied in the environment of a family document.
|
See Also