TemporaryViewModesIsValidState Method |
Tests whether the given state is valid for the associated view and the context the view is currently in.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidState(
PreviewFamilyVisibilityMode state
)
Public Function IsValidState (
state As PreviewFamilyVisibilityMode
) As Boolean
public:
bool IsValidState(
PreviewFamilyVisibilityMode state
)
member IsValidState :
state : PreviewFamilyVisibilityMode -> bool
Parameters
- state PreviewFamilyVisibilityMode
-
A state of the PreviewFamilyVisibilityMode
Return Value
Boolean
Returns True if the state is applicable for the view; False otherwise.
Exceptions
Remarks
As long as the PreviewFamilyVisibility mode is available and enabled in the associated view,
the Off and On states are always valid. However, the Uncut state is only
valid in plan views and reflected ceilings.
See Also