TemporaryViewModesDeactivateMode Method |
Deactivates the given temporary mode.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void DeactivateMode(
TemporaryViewMode mode
)
Public Sub DeactivateMode (
mode As TemporaryViewMode
)
public:
void DeactivateMode(
TemporaryViewMode mode
)
member DeactivateMode :
mode : TemporaryViewMode -> unit
Parameters
- mode TemporaryViewMode
-
The mode to deactivate
ExceptionsException | Condition |
---|
ArgumentException |
The temporary mode is not available in the associated view.
The view is either of a type that does not support this mode,
or is currently in a context that makes the mode presently inapplicable.
-or-
The temporary mode is presently not enabled in the associated view.
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
The method has no effect on modes that are already deactivated.
See Also