STLExportOptions Class

The export options used by exporting STL format file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBIMExportOptions
    Autodesk.Revit.DBSTLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class STLExportOptions : BIMExportOptions

The STLExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodSTLExportOptions Constructs a new instance of STLExportOptions with default values of all properties.
Public methodSTLExportOptions(ExportResolution) Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
Properties
 NameDescription
Public propertyExportBinary True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public propertyExportColor True to export color information, false otherwise. Default value is false.
Public propertyGridAspectRatio The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BIMExportOptions)
Public propertyMaxEdgeLength The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public propertyNormalTolerance The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public propertySurfaceTolerance The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public propertyTargetUnit The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.
Public propertyViewId The element id of the 3D view to export. InvalidElementId by default.
(Inherited from BIMExportOptions)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from BIMExportOptions)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsGridAspectRatioSet Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public methodIsMaxEdgeLengthSet Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public methodIsNormalToleranceSet Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public methodIsSurfaceToleranceSet Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
Public methodStatic memberIsValidForGridAspectRatio Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
Public methodStatic memberIsValidForMaxEdgeLength Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
Public methodStatic memberIsValidForNormalTolerance Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
Public methodStatic memberIsValidForSurfaceTolerance Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public methodSetTessellationSettings Sets all the tessellation parameters to its predefined values for the given resolution type.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also