STLExportOptionsGridAspectRatio Property |
The maximum aspect ratio allowed in the grid placed across the face.
The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GridAspectRatio { get; set; }
Public Property GridAspectRatio As Double
Get
Set
public:
property double GridAspectRatio {
double get ();
void set (double value);
}
member GridAspectRatio : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The value gridAspectRatio is outside the allowable range of values for GridAspectRatio tessellation parameter.
|
InvalidOperationException |
GridAspectRatio tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
|
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method).
In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0) and it is considered as explicitly set by the user.
In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also