STLExportOptionsNormalTolerance Property |
The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees.
The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double NormalTolerance { get; set; }
Public Property NormalTolerance As Double
Get
Set
public:
property double NormalTolerance {
double get ();
void set (double value);
}
member NormalTolerance : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The value normalTolerance is outside the allowable range of values for NormalTolerance tessellation parameter.
|
InvalidOperationException |
NormalTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
|
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method).
In the case of Fine (10.0 degrees), Medium (15.0 degrees) and Coarse (30.0 degrees) resolutions, this property is considered as explicitly set by the user.
In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also