MultiReferenceAnnotationOptions Class

Options which control the creation of MultiReferenceAnnotations.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBMultiReferenceAnnotationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MultiReferenceAnnotationOptions : IDisposable

The MultiReferenceAnnotationOptions type exposes the following members.

Constructors
 NameDescription
Public methodMultiReferenceAnnotationOptions Create an instance of Multi-Reference Annotation Options set with default values.
Top
Properties
 NameDescription
Public propertyDimensionLineDirection The direction vector of the dimension line.
Public propertyDimensionLineOrigin The origin point for the dimension line.
Public propertyDimensionPlaneNormal The normal vector to the dimension plane.
Public propertyDimensionStyleType The dimension style type to be used by the new MultiReferenceAnnotation.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMultiReferenceAnnotationType The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public propertyTagHasLeader When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public propertyTagHeadPosition The position for the tag's head.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the MultiReferenceAnnotationOptions
Public methodElementsMatchReferenceCategory Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public methodGetAdditionalReferencesToDimension Gets the additional references which the dimension will witness.
Public methodGetElementsToDimension Gets the elements which the dimension will witness.
Public methodIsAllowedDimensionStyleType Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public methodReferencesDontMatchReferenceCategory Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public methodSetAdditionalReferencesToDimension Sets the additional references which the dimension will witness.
Public methodSetElementsToDimension Sets the elements which the dimension will witness.
Top
Remarks
MultiReferenceAnnotationOptions include the specification of the associated elements and options for the dimension and tag placement.
See Also