MultiReferenceAnnotationOptionsSetElementsToDimension Method |
Sets the elements which the dimension will witness.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetElementsToDimension(
ICollection<ElementId> elementsToDimension
)
Public Sub SetElementsToDimension (
elementsToDimension As ICollection(Of ElementId)
)
public:
void SetElementsToDimension(
ICollection<ElementId^>^ elementsToDimension
)
member SetElementsToDimension :
elementsToDimension : ICollection<ElementId> -> unit
Parameters
- elementsToDimension ICollectionElementId
-
The elements which the dimension will witness.
ExceptionsException | Condition |
---|
ArgumentException |
some elements do not match the reference category required by the MultiReferenceAnnotationType.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The MultiReferenceAnnotationType assigned to the options can't create MultiReferenceAnnotations by element.
|
Remarks
The dimension will automatically find geometric references in the elements.
See Also