MultiReferenceAnnotationOptionsSetAdditionalReferencesToDimension Method |
Sets the additional references which the dimension will witness.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetAdditionalReferencesToDimension(
IList<Reference> referencesToDimension
)
Public Sub SetAdditionalReferencesToDimension (
referencesToDimension As IList(Of Reference)
)
public:
void SetAdditionalReferencesToDimension(
IList<Reference^>^ referencesToDimension
)
member SetAdditionalReferencesToDimension :
referencesToDimension : IList<Reference> -> unit
Parameters
- referencesToDimension IListReference
-
The additional references which the dimension will witness.
ExceptionsException | Condition |
---|
ArgumentException |
Some references come from elements which directly match the reference category required by the MultiReferenceAnnotationType. For
those elements please use SetElementsToDimension.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The additional references to dimension cannot come from the same category as the MultiReferenceAnnotationType's reference category.
See Also