UnitUtils Class

A utility class of functions related to units.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBUnitUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UnitUtils

The UnitUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberConvert Converts a value from one unit to another, such as square feet to square meters.
Public methodStatic memberConvertFromInternalUnits Converts a value from Revit's internal units to a given unit.
Public methodStatic memberConvertToInternalUnits Converts a value from a given unit to Revit's internal units.
Public methodStatic memberGetAllDisciplines Gets the identifiers of all available disciplines.
Public methodStatic memberGetAllMeasurableSpecs Gets the identifiers of all available measurable specs.
Public methodStatic memberGetAllUnits Gets the identifiers of all available units.
Public methodStatic memberGetDiscipline Gets the discipline for a given measurable spec.
Public methodStatic memberGetTypeCatalogStringForSpec Gets the string used in type catalogs to identify a given measurable spec.
Public methodStatic memberGetTypeCatalogStringForUnit Gets the string used in type catalogs to identify a given unit.
Public methodStatic memberGetValidUnits Gets the identifiers of all valid units for a given measurable spec.
Public methodStatic memberIsMeasurableSpec Checks whether a ForgeTypeId identifies a spec associated with units of measurement.
Public methodStatic memberIsSymbol Checks whether a ForgeTypeId identifies a symbol.
Public methodStatic memberIsUnit Checks whether a ForgeTypeId identifies a unit.
Public methodStatic memberIsValidUnit Checks whether a unit is valid for a given measurable spec.
Top
See Also