UnitUtilsGetValidUnits Method |
Gets the identifiers of all valid units for a given measurable spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ForgeTypeId> GetValidUnits(
ForgeTypeId specTypeId
)
Public Shared Function GetValidUnits (
specTypeId As ForgeTypeId
) As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetValidUnits(
ForgeTypeId^ specTypeId
)
static member GetValidUnits :
specTypeId : ForgeTypeId -> IList<ForgeTypeId>
Parameters
- specTypeId ForgeTypeId
-
Identifier of the measurable spec.
Return Value
IListForgeTypeId
Identifiers of the valid units.
Exceptions
See Also