UnitUtilsIsValidUnit Method |
Checks whether a unit is valid for a given measurable spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidUnit(
ForgeTypeId specTypeId,
ForgeTypeId unitTypeId
)
Public Shared Function IsValidUnit (
specTypeId As ForgeTypeId,
unitTypeId As ForgeTypeId
) As Boolean
public:
static bool IsValidUnit(
ForgeTypeId^ specTypeId,
ForgeTypeId^ unitTypeId
)
static member IsValidUnit :
specTypeId : ForgeTypeId *
unitTypeId : ForgeTypeId -> bool
Parameters
- specTypeId ForgeTypeId
-
Identifier of the measurable spec.
- unitTypeId ForgeTypeId
-
Identifier of the unit to check.
Return Value
Boolean
True if the unit is valid, false otherwise.
Exceptions
See Also