UnitUtilsConvertToInternalUnits Method |
Converts a value from a given unit to Revit's internal units.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static double ConvertToInternalUnits(
double value,
ForgeTypeId unitTypeId
)
Public Shared Function ConvertToInternalUnits (
value As Double,
unitTypeId As ForgeTypeId
) As Double
public:
static double ConvertToInternalUnits(
double value,
ForgeTypeId^ unitTypeId
)
static member ConvertToInternalUnits :
value : float *
unitTypeId : ForgeTypeId -> float
Parameters
- value Double
-
The value to convert.
- unitTypeId ForgeTypeId
-
Identifier of the unit quantifying the value.
Return Value
Double
The converted value.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for value is not finite
-or-
unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
|
ArgumentNullException |
A non-optional argument was null
|
See Also