UnitUtilsGetTypeCatalogStringForUnit Method |
Gets the string used in type catalogs to identify a given unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static string GetTypeCatalogStringForUnit(
ForgeTypeId unitTypeId
)
Public Shared Function GetTypeCatalogStringForUnit (
unitTypeId As ForgeTypeId
) As String
public:
static String^ GetTypeCatalogStringForUnit(
ForgeTypeId^ unitTypeId
)
static member GetTypeCatalogStringForUnit :
unitTypeId : ForgeTypeId -> string
Parameters
- unitTypeId ForgeTypeId
-
Identifier of the unit.
Return Value
String
The type catalog string, or an empty string if the unit cannot be used in type catalogs.
ExceptionsException | Condition |
---|
ArgumentException |
unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
|
ArgumentNullException |
A non-optional argument was null
|
See Also