FabricationNetworkChangeService Class

This class represents the fabrication part change service and change size tools.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.FabricationFabricationNetworkChangeService

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationNetworkChangeService : IDisposable

The FabricationNetworkChangeService type exposes the following members.

Constructors
 NameDescription
Public methodFabricationNetworkChangeService Creates a new instance of the FabricationNetworkChangeService class.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodApplyChange Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.
Public methodChangeService(ISetElementId, Int32, Int32) Changes the service of the selection of fabrication parts.
Public methodChangeService(ISetElementId, Int32, Int32, Boolean) Changes the service of the selection of fabrication parts.
Public methodChangeSize Changes the size of the selection of fabrication parts.
Public methodDisposeReleases all resources used by the FabricationNetworkChangeService
Public methodGetElementsThatFailed Gets the set of fabrication parts that had failures due to either there was no corresponding part in the service, the size was out of range, or a connection could not be made.
Public methodGetInLinePartTypes Get a set of element identifiers of fabrication part types for in-line parts.
Public methodGetMapOfAllSizesForStraights Get a set of FabricationPartSizeMapSet of all straight sizes for all services.
Public methodGetStraightsThatWereNotChanged Gets the set of fabrication part straights that were not changed due to either there was no corresponding part in the service or the size was out of range.
Public methodSetMapOfInLinePartTypes Set the mapping of fabrication part types for in-line parts for the service and palette to change to.
Public methodSetMapOfSizesForStraights Set the mapping for sizes of fabrication part straights to change the sizes to.
Public methodSetPaletteId Set the fabrication palette identifier to change the elements to.
Public methodSetRestrictPalette Restrict the placement of parts to only use parts associated to the passed in fabrication palette identifier.
Public methodSetSelection Set the element selection to change the service or size for.
Public methodSetServiceId Set the fabrication service identifier to change the elements to.
Top
Remarks
After a new instance of the class is created, call the ChangeService method to change the service of the fabrication parts or call the ChangeSize method to change the size of the fabrication parts. There is another workflow allowing for more control, call SetSelection to set the selection of fabrication parts to change. To change the service, call SetServiceId and SetPaletteId to set the service identifier and palette identifier. Changing the service there is an optional methods GetInLinePartTypes and SetMapOfSizesForStraights that can be called to replace in-line valves and dampers to the corresponding parts for the new service. The size can also be changed by calling GetMapOfAllSizesForStraights that will return a FabricationPartSizeMapSet containing a map of sizes for all straights found in the selection of fabrication parts. The FabricationPartSizeMapSet can then be modified to set the mapped values for the new size for the fabrication part straights and then call SetMapOfSizesForStraights set the new sizes that are to be applied. Finally call ApplyChange to apply the previously set parameters to the selection of fabrication parts.
See Also