FabricationNetworkChangeServiceChangeSize Method |
Changes the size of the selection of fabrication parts.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FabricationNetworkChangeServiceResult ChangeSize(
ISet<ElementId> selection,
ISet<FabricationPartSizeMap> fabricationPartSizeMaps
)
Public Function ChangeSize (
selection As ISet(Of ElementId),
fabricationPartSizeMaps As ISet(Of FabricationPartSizeMap)
) As FabricationNetworkChangeServiceResult
public:
FabricationNetworkChangeServiceResult ChangeSize(
ISet<ElementId^>^ selection,
ISet<FabricationPartSizeMap^>^ fabricationPartSizeMaps
)
member ChangeSize :
selection : ISet<ElementId> *
fabricationPartSizeMaps : ISet<FabricationPartSizeMap> -> FabricationNetworkChangeServiceResult
Parameters
- selection ISetElementId
-
The set of element identifiers of fabrication parts to change the size for.
- fabricationPartSizeMaps ISetFabricationPartSizeMap
-
The map containing the original sizes for the straights to the new sizes.
Return Value
FabricationNetworkChangeServiceResult
Exceptions
Remarks
After this method has been invoked, call:
See Also