ComboBox Class

This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    Autodesk.Revit.UIComboBox

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ComboBox : RibbonItem

The ComboBox type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets or sets the current checked ComboBox member of the ComboBox.
Public propertyEnabledGets or sets a value indicating whether the item is enabled.
(Inherited from RibbonItem)
Public propertyImageThe image shown on the ComboBox.
Public propertyItemTextGets or sets the text displayed on the item.
(Inherited from RibbonItem)
Public propertyItemTypeGets the item type.
(Inherited from RibbonItem)
Public propertyLongDescription Long description of the command tooltip
(Inherited from RibbonItem)
Public propertyNameThe name of the item.
(Inherited from RibbonItem)
Public propertyToolTipThe description that appears as a ToolTip for the item.
(Inherited from RibbonItem)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
(Inherited from RibbonItem)
Public propertyVisibleGets or sets a value indicating whether the item is visible.
(Inherited from RibbonItem)
Top
Methods
 NameDescription
Public methodAddItemAdds a new item to the ComboBox.
Public methodAddItemsAdds a new items to the ComboBox.
Public methodAddSeparatorAdds a separator to the drop-down list.
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from RibbonItem)
Public methodGetContextualHelpGets the contextual help bound with this control.
(Inherited from RibbonItem)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetItemsGets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button.
(Inherited from RibbonItem)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Events
 NameDescription
Public eventCurrentChangedSubscribe to this event to be notified when the current item of the ComboBox is changed.
Public eventDropDownClosedSubscribe to this event to be notified when the drop-down of the ComboBox is closed.
Public eventDropDownOpenedSubscribe to this event to be notified when the drop-down of the ComboBox is opened.
Top
Remarks
The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit Macros.
See Also