ParameterFilterRuleFactory Class

Contains functions that create appropriate FilterRule objects based on the parameters given.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBParameterFilterRuleFactory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterFilterRuleFactory : IDisposable

The ParameterFilterRuleFactory type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberCreateBeginsWithRule(ElementId, String) Creates a filter rule that determines whether strings from the document begin with a certain string value.
Public methodStatic memberCreateBeginsWithRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document begin with a certain string value.
Public methodStatic memberCreateContainsRule(ElementId, String) Creates a filter rule that determines whether strings from the document contain a certain string value.
Public methodStatic memberCreateContainsRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document contain a certain string value.
Public methodStatic memberCreateEndsWithRule(ElementId, String) Creates a filter rule that determines whether strings from the document end with a certain string value.
Public methodStatic memberCreateEndsWithRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document end with a certain string value.
Public methodStatic memberCreateEqualsRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document equal a certain value.
Public methodStatic memberCreateEqualsRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document equal a certain value.
Public methodStatic memberCreateEqualsRule(ElementId, String) Creates a filter rule that determines whether strings from the document equal a certain value.
Public methodStatic memberCreateEqualsRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document equal a certain value.
Public methodStatic memberCreateEqualsRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document equal a certain value.
Public methodStatic memberCreateGreaterOrEqualRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
Public methodStatic memberCreateGreaterOrEqualRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
Public methodStatic memberCreateGreaterOrEqualRule(ElementId, String) Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
Public methodStatic memberCreateGreaterOrEqualRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
Public methodStatic memberCreateGreaterOrEqualRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
Public methodStatic memberCreateGreaterRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
Public methodStatic memberCreateGreaterRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are greater than a certain value.
Public methodStatic memberCreateGreaterRule(ElementId, String) Creates a filter rule that determines whether strings from the document are greater than a certain value.
Public methodStatic memberCreateGreaterRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
Public methodStatic memberCreateGreaterRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document are greater than a certain value.
Public methodStatic memberCreateHasNoValueParameterRule Creates a filter rule that determines whether an element's parameter does not have a value.
Public methodStatic memberCreateHasValueParameterRule Creates a filter rule that determines whether an element's parameter has a value.
Public methodStatic memberCreateIsAssociatedWithGlobalParameterRule Creates a filter rule that determines whether a parameter is associated with a certain global parameter.
Public methodStatic memberCreateIsNotAssociatedWithGlobalParameterRule Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.
Public methodStatic memberCreateLessOrEqualRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
Public methodStatic memberCreateLessOrEqualRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
Public methodStatic memberCreateLessOrEqualRule(ElementId, String) Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
Public methodStatic memberCreateLessOrEqualRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
Public methodStatic memberCreateLessOrEqualRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
Public methodStatic memberCreateLessRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
Public methodStatic memberCreateLessRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are less than a certain value.
Public methodStatic memberCreateLessRule(ElementId, String) Creates a filter rule that determines whether strings from the document are less than a certain value.
Public methodStatic memberCreateLessRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
Public methodStatic memberCreateLessRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document are less than a certain value.
Public methodStatic memberCreateNotBeginsWithRule(ElementId, String) Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
Public methodStatic memberCreateNotBeginsWithRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
Public methodStatic memberCreateNotContainsRule(ElementId, String) Creates a filter rule that determines whether strings from the document do not contain a certain string value.
Public methodStatic memberCreateNotContainsRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document do not contain a certain string value.
Public methodStatic memberCreateNotEndsWithRule(ElementId, String) Creates a filter rule that determines whether strings from the document do not end with a certain string value.
Public methodStatic memberCreateNotEndsWithRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document do not end with a certain string value.
Public methodStatic memberCreateNotEqualsRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
Public methodStatic memberCreateNotEqualsRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document do not equal a certain value.
Public methodStatic memberCreateNotEqualsRule(ElementId, String) Creates a filter rule that determines whether strings from the document do not equal a certain value.
Public methodStatic memberCreateNotEqualsRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
Public methodStatic memberCreateNotEqualsRule(ElementId, String, Boolean)Obsolete.
Creates a filter rule that determines whether strings from the document do not equal a certain value.
Public methodStatic memberCreateSharedParameterApplicableRule Creates a filter rule that tests elements for support of a shared parameter.
Public methodDisposeReleases all resources used by the ParameterFilterRuleFactory
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also