ParameterFilterRuleFactoryCreateGreaterRule(ElementId, String, Boolean) Method |
Note: This API is now obsolete.
Creates a filter rule that determines whether strings from the document are greater than a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterRule(
ElementId parameter,
string value,
bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateGreaterRule (
parameter As ElementId,
value As String,
caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateGreaterRule(
ElementId^ parameter,
String^ value,
bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateGreaterRule :
parameter : ElementId *
value : string *
caseSensitive : bool -> FilterRule
Parameters
- parameter ElementId
-
A string-typed parameter used to get values from the document for a given element.
- value String
-
The user-supplied string value against which values from the document will be compared.
- caseSensitive Boolean
-
If true, the string comparison will be case-sensitive.
Return Value
FilterRule
Exceptions
Remarks
For strings, a value is "greater" than another if it would appear after
the other in an alphabetically-sorted list.
See Also