ParameterFilterRuleFactoryCreateLessRule(ElementId, String) Method |
Creates a filter rule that determines whether strings from the document
are less than a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FilterRule CreateLessRule(
ElementId parameter,
string value
)
Public Shared Function CreateLessRule (
parameter As ElementId,
value As String
) As FilterRule
public:
static FilterRule^ CreateLessRule(
ElementId^ parameter,
String^ value
)
static member CreateLessRule :
parameter : ElementId *
value : string -> FilterRule
Parameters
- parameter ElementId
-
A string-typed parameter used to get values from the document for a given element.
- value String
-
The user-supplied string value against which values from the document will be compared.
Return Value
FilterRule
Created filter rule object.
Exceptions
Remarks
For strings, a value is "less" than another if it would appear before
the other in an alphabetically-sorted list.
See Also