ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, Double, Double) Method |
Creates a filter rule that determines whether double-precision values
from the document are greater than or equal to a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FilterRule CreateGreaterOrEqualRule(
ElementId parameter,
double value,
double epsilon
)
Public Shared Function CreateGreaterOrEqualRule (
parameter As ElementId,
value As Double,
epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateGreaterOrEqualRule(
ElementId^ parameter,
double value,
double epsilon
)
static member CreateGreaterOrEqualRule :
parameter : ElementId *
value : float *
epsilon : float -> FilterRule
Parameters
- parameter ElementId
-
A double-typed parameter used to get values from the document for a given element.
- value Double
-
The user-supplied value against which values from the document will be compared.
- epsilon Double
-
Defines the tolerance within which two values may be considered equal.
Return Value
FilterRule
ExceptionsException | Condition |
---|
ArgumentException |
The given value for value is not finite
-or-
The given value for value is not a number
-or-
The given value for epsilon is not finite
-or-
The given value for epsilon is not a number
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
Values less than the user-supplied value but within epsilon
are considered equal; therefore, such values satisfy the condition.
See Also