ParameterFilterRuleFactoryCreateIsAssociatedWithGlobalParameterRule Method

Creates a filter rule that determines whether a parameter is associated with a certain global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FilterRule CreateIsAssociatedWithGlobalParameterRule(
	ElementId parameter,
	ElementId value
)

Parameters

parameter  ElementId
A parameter that can be associated with an existing global parameter of a compatible type.
value  ElementId
The global parameter used to test the association.

Return Value

FilterRule
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also