ParameterFilterRuleFactoryCreateNotBeginsWithRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FilterRule CreateNotBeginsWithRule(
	ElementId parameter,
	string value
)

Parameters

parameter  ElementId
A string-typed parameter used to get values from the document for a given element.
value  String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also