IFCImportOptionsForceImport Property |
Force the IFC file to be imported regardless of an existing corresponding Revit file.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ForceImport { get; set; }
Public Property ForceImport As Boolean
Get
Set
public:
property bool ForceImport {
bool get ();
void set (bool value);
}
member ForceImport : bool with get, set
Property Value
Boolean
Remarks
If this value is true (default), we will perform the import even if the existing corresponding Revit file is up-to-date.
If this value is false, then we will re-use an existing RVT file if it is up-to-date.
The intention is for ForceImport to be false during host file open while reloading links,
and true during link reload via the Manage Links API.
See Also