IFCImportOptionsAutoJoin Property |
Enable or disable auto-join at the end of import.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AutoJoin { get; set; }
Public Property AutoJoin As Boolean
Get
Set
public:
property bool AutoJoin {
bool get ();
void set (bool value);
}
member AutoJoin : bool with get, set
Property Value
Boolean
Remarks
Enabling auto-join will join appropriate elements (e.g., walls, columns), but will take extra time and may fail.
Disabling auto-join will allow some imports that otherwise fail.
Default is true for Open IFC; it is ignored (and false) for Link IFC.
See Also