SolidSolidCutUtils Class

Exposes utilities which can cause one solid to cut another.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSolidSolidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SolidSolidCutUtils

The SolidSolidCutUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAddCutBetweenSolids(Document, Element, Element) Adds a solid-solid cut for the two elements.
Public methodStatic memberAddCutBetweenSolids(Document, Element, Element, Boolean) Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
Public methodStatic memberCanElementCutElement Verifies if the cutting element can add a solid cut to the target element.
Public methodStatic memberCutExistsBetweenElements Checks that if there is a solid-solid cut between two elements.
Public methodStatic memberGetCuttingSolids Gets all the solids which cut the input element.
Public methodStatic memberGetSolidsBeingCut Get all the solids which are cut by the input element.
Public methodStatic memberIsAllowedForSolidCut Validates that the element is eligible for a solid-solid cut.
Public methodStatic memberIsElementFromAppropriateContext Validates that the element is from an appropriate document.
Public methodStatic memberRemoveCutBetweenSolids Removes the solid-solid cut between the two elements if it exists.
Public methodStatic memberSplitFacesOfCuttingSolid Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Top
Remarks
These utilities are applicable for the generic forms, geometry combinations and family instances in conceptual model, pattern based curtain panel, or adaptive component families, and family instances which are permitted to participate in joining in projects. Thus, for example, a beam cannot cut a wall (as the wall is not a family instance) in projects. Nor can a steel beam participate in cutting another family (because steel beams do not participate in joining).
See Also