SolidSolidCutUtilsCutExistsBetweenElements Method |
Checks that if there is a solid-solid cut between two elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CutExistsBetweenElements(
Element first,
Element second,
out bool firstCutsSecond
)
Public Shared Function CutExistsBetweenElements (
first As Element,
second As Element,
<OutAttribute> ByRef firstCutsSecond As Boolean
) As Boolean
public:
static bool CutExistsBetweenElements(
Element^ first,
Element^ second,
[OutAttribute] bool% firstCutsSecond
)
static member CutExistsBetweenElements :
first : Element *
second : Element *
firstCutsSecond : bool byref -> bool
Parameters
- first Element
-
The solid being cut or the cutting solid.
- second Element
-
The solid being cut or the cutting solid.
- firstCutsSecond Boolean
-
If the return value of this function is true, this indicates which element is the cutting element from the pair.
True if the first solid cuts the second one, false if the second solid cuts the first one.
Return Value
Boolean
True if there is a solid-solid cut between the input elements, false otherwise.
Exceptions
See Also