SolidSolidCutUtilsIsAllowedForSolidCut Method |
Validates that the element is eligible for a solid-solid cut.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsAllowedForSolidCut(
Element element
)
Public Shared Function IsAllowedForSolidCut (
element As Element
) As Boolean
public:
static bool IsAllowedForSolidCut(
Element^ element
)
static member IsAllowedForSolidCut :
element : Element -> bool
Parameters
- element Element
-
The solid to be cut or the cutting solid.
Return Value
Boolean
True if the input element can participate in a solid-solid cut. False otherwise.
Exceptions
Remarks
The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
See Also