SolidSolidCutUtilsCanElementCutElement Method |
Verifies if the cutting element can add a solid cut to the target element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanElementCutElement(
Element cuttingElement,
Element cutElement,
out CutFailureReason reason
)
Public Shared Function CanElementCutElement (
cuttingElement As Element,
cutElement As Element,
<OutAttribute> ByRef reason As CutFailureReason
) As Boolean
public:
static bool CanElementCutElement(
Element^ cuttingElement,
Element^ cutElement,
[OutAttribute] CutFailureReason% reason
)
static member CanElementCutElement :
cuttingElement : Element *
cutElement : Element *
reason : CutFailureReason byref -> bool
Parameters
- cuttingElement Element
-
The cutting element.
- cutElement Element
-
The element to be cut.
- reason CutFailureReason
-
The reason that the cutting element cannot add a solid cut to the cut element.
Return Value
Boolean
True if the cutting element can add a solid cut to the target element, false otherwise.
Exceptions
See Also