SolidSolidCutUtilsSplitFacesOfCuttingSolid Method |
Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SplitFacesOfCuttingSolid(
Element first,
Element second,
bool split
)
Public Shared Sub SplitFacesOfCuttingSolid (
first As Element,
second As Element,
split As Boolean
)
public:
static void SplitFacesOfCuttingSolid(
Element^ first,
Element^ second,
bool split
)
static member SplitFacesOfCuttingSolid :
first : Element *
second : Element *
split : bool -> unit
Parameters
- first Element
-
The solid being cut or the cutting solid
- second Element
-
The solid being cut or the cutting solid
- split Boolean
-
True to split the faces of intersection, false to unsplit them.
Exceptions
Remarks
There must be a cut between the input elements.
See Also