SolidSolidCutUtilsIsElementFromAppropriateContext Method |
Validates that the element is from an appropriate document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsElementFromAppropriateContext(
Element element
)
Public Shared Function IsElementFromAppropriateContext (
element As Element
) As Boolean
public:
static bool IsElementFromAppropriateContext(
Element^ element
)
static member IsElementFromAppropriateContext :
element : Element -> bool
Parameters
- element Element
-
The solid to be cut or the cutting solid.
Return Value
Boolean
True if the element is from an appropriate document for solid-solid cuts, false otherwise.
Exceptions
Remarks
Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family
may participate in solid-solid cuts.
See Also