SolidSolidCutUtilsAddCutBetweenSolids(Document, Element, Element) Method |
Adds a solid-solid cut for the two elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AddCutBetweenSolids(
Document document,
Element solidToBeCut,
Element cuttingSolid
)
Public Shared Sub AddCutBetweenSolids (
document As Document,
solidToBeCut As Element,
cuttingSolid As Element
)
public:
static void AddCutBetweenSolids(
Document^ document,
Element^ solidToBeCut,
Element^ cuttingSolid
)
static member AddCutBetweenSolids :
document : Document *
solidToBeCut : Element *
cuttingSolid : Element -> unit
Parameters
- document Document
-
The document containing the two elements.
- solidToBeCut Element
-
The solid to be cut.
- cuttingSolid Element
-
The cutting solid.
ExceptionsException | Condition |
---|
ArgumentException |
The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family.
-or-
The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Failed to add solid-solid cut for the two elements.
|
Remarks
This utility will split faces of cutting solid by default.
See Also