FamilyInstanceCreationData Class

A class which wraps the arguments of FamilyInstance for batch creation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.CreationFamilyInstanceCreationData

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyInstanceCreationData

The FamilyInstanceCreationData type exposes the following members.

Constructors
 NameDescription
Public methodFamilyInstanceCreationData(Object)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(FamilySymbol, IListXYZ)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(Face, Line, FamilySymbol)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Public methodFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType)Initializes a new instance of the FamilyInstanceCreationData class
Top
Properties
 NameDescription
Public propertyAxis Get or set the axis of the FamilyInstance
Public propertyRotateAngle Get or set the rotate angle of the FamilyInstance
Top
Methods
 NameDescription
Top
See Also