FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Constructor |
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData(
XYZ location,
FamilySymbol symbol,
StructuralType structuralType
)
Public Sub New (
location As XYZ,
symbol As FamilySymbol,
structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
XYZ^ location,
FamilySymbol^ symbol,
StructuralType structuralType
)
new :
location : XYZ *
symbol : FamilySymbol *
structuralType : StructuralType -> FamilyInstanceCreationData
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- structuralType StructuralType
- Specify if the family instance is structural.
See Also