FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Constructor |
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData(
XYZ location,
FamilySymbol symbol,
Level level,
StructuralType structuralType
)
Public Sub New (
location As XYZ,
symbol As FamilySymbol,
level As Level,
structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
XYZ^ location,
FamilySymbol^ symbol,
Level^ level,
StructuralType structuralType
)
new :
location : XYZ *
symbol : FamilySymbol *
level : Level *
structuralType : StructuralType -> FamilyInstanceCreationData
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- level Level
- A Level object that is used as the base level for the object.
- structuralType StructuralType
- If structural then specify the type of the component.
See Also