FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Constructor |
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData(
XYZ location,
FamilySymbol symbol,
Element host,
StructuralType structuralType
)
Public Sub New (
location As XYZ,
symbol As FamilySymbol,
host As Element,
structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
XYZ^ location,
FamilySymbol^ symbol,
Element^ host,
StructuralType structuralType
)
new :
location : XYZ *
symbol : FamilySymbol *
host : Element *
structuralType : StructuralType -> FamilyInstanceCreationData
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- host Element
- The object into which the FamilyInstance is to be inserted, often known as the host.
- structuralType StructuralType
- If structural then specify the type of the component.
See Also