FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Constructor |
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData(
Curve curve,
FamilySymbol symbol,
Level level,
StructuralType structuralType
)
Public Sub New (
curve As Curve,
symbol As FamilySymbol,
level As Level,
structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
Curve^ curve,
FamilySymbol^ symbol,
Level^ level,
StructuralType structuralType
)
new :
curve : Curve *
symbol : FamilySymbol *
level : Level *
structuralType : StructuralType -> FamilyInstanceCreationData
Parameters
- curve Curve
- The curve where the instance is based.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- level Level
- A Level object that is used as the base level for the object.
- structuralType StructuralType
- If structural then specify the type of the component.
See Also