ElectricalEquipment Class

Provides access to the Electrical Equipment in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      Autodesk.Revit.DB.ElectricalElectricalEquipment

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalEquipment : MEPModel

The ElectricalEquipment type exposes the following members.

Properties
 NameDescription
Public propertyCircuitNamingSchemeId The CircuitNamingSchemeId used in the Electrical Equipment. The CircuitNamingSchemeId is used to retrieve the circuit naming scheme id of the Electrical Equipment.
Public propertyConnectorManager Retrieves the Connector Manager from this MEPModel.
(Inherited from MEPModel)
Public propertyDistributionSystem get or set the Distribution System for the Electrical Equipment.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsSwitchboard The electrical equipment is a switchboard or not. This property returns true if the electrical equipment is a switchboard.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MEPModel)
Public propertyMaxNumberOfCircuits The maximum number of circuits for switchboard. The quantity of circuits can be assigned to switchboard through breaker.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAssignedElectricalSystems Retrieves the electrical systems this electrical panel currently is assigned to.
(Inherited from MEPModel)
Public methodGetCircuitNamingSchemeType Gets enumerated type of the circuit naming scheme used with Electrical Equipment.
Public methodGetElectricalSystems Retrieves the electrical systems that are currently created using this MEPModel.
(Inherited from MEPModel)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidCircuitNamingSchemeId Verifies that the circuit naming scheme id can be used with Electrical Equipment.
Public methodIsValidDistributionSystem Verifies that the Distribution System can be assigned to the Electrical Equipment.
Public methodSetCircuitNamingSchemeType Sets the circuit naming scheme for Electrical Equipment.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also