ElectricalEquipment Class

Provides access to the Electrical Equipment in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      Autodesk.Revit.DB.ElectricalElectricalEquipment

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalEquipment : MEPModel

The ElectricalEquipment type exposes the following members.

Properties
 NameDescription
Public propertyCircuitNamingSchemeId The CircuitNamingSchemeId used in the Electrical Equipment. The CircuitNamingSchemeId is used to retrieve the circuit naming scheme id of the Electrical Equipment.
Public propertyDistributionSystem get or set the Distribution System for the Electrical Equipment.
Public propertyIsSwitchboard The electrical equipment is a switchboard or not. This property returns true if the electrical equipment is a switchboard.
Public propertyMaxNumberOfCircuits The maximum number of circuits for switchboard. The quantity of circuits can be assigned to switchboard through breaker.
Top
Methods
 NameDescription
Public methodGetCircuitNamingSchemeType Gets enumerated type of the circuit naming scheme used with Electrical Equipment.
Public methodStatic memberIsValidCircuitNamingSchemeId Verifies that the circuit naming scheme id can be used with Electrical Equipment.
Public methodIsValidDistributionSystem Verifies that the Distribution System can be assigned to the Electrical Equipment.
Public methodSetCircuitNamingSchemeType Sets the circuit naming scheme for Electrical Equipment.
Top
See Also