ElectricalEquipmentDistributionSystem Property |
get or set the Distribution System for the Electrical Equipment.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DistributionSysType DistributionSystem { get; set; }
Public Property DistributionSystem As DistributionSysType
Get
Set
public:
property DistributionSysType^ DistributionSystem {
DistributionSysType^ get ();
void set (DistributionSysType^ value);
}
member DistributionSystem : DistributionSysType with get, set
Property Value
DistributionSysType
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The Distribution System can not be assigned to the Electrical Equipment.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
This property returns a Distribution System which is assigned to the Electrical Equipment.
If there are no Distribution System assigned to this Electrical Equipment,
this property will be .
See Also