MEPModel Class

Supports all MEP models that are persistent within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPModel : APIObject

The MEPModel type exposes the following members.

Properties
 NameDescription
Public propertyConnectorManager Retrieves the Connector Manager from this MEPModel.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodGetAssignedElectricalSystems Retrieves the electrical systems this electrical panel currently is assigned to.
Public methodGetElectricalSystems Retrieves the electrical systems that are currently created using this MEPModel.
Top
See Also
Inheritance Hierarchy